JXU's Blog

音楽、バイク、旅行、無線その他の一言を‥

raspberrypiでグループウェア運用の件

手元のraspberry pi 3B +、以前設定して調子良く動いてるグループウェアの設定方法を整理すべく、まっさらな状態から再設定に取り組んでいました。

 

ただ、新規にOSをインストール、その後にopenJDK13、次にapache-tomcatのをインストールするまでは良いが、warファイルがどうしても開けませんでした。

 

何度も設定変更を試みたところ、単にapache-tomcatのバージョンとの間に問題がある事がわかりました。

f:id:mnb9:20200309065847j:image

raspbian buster-liteと

apache-tomcat9.0.31又は10.0.0-M1の組み合わせでは動かないです。

なので、8.5.5だったかな?

apache-tomcatは少し前のバージョンにしました。

そうすると簡単にwarファイルが開けて使えました💦

 

もう少し頑張って、インストール方法を整理してからブログへの再掲載したいと思います。